giovedì 7 maggio 2015

SDRSharp - RTL_TCP Bug solved :)

If you have this problem, i've found a solution...

Problem is starting at 01:00 here:

 



Problem is starting at 01:35 here:





The bug is related to the RTLTCP driver that's included now with SDRSharp by default.
After spending more than one year trying to fix this problem, i've tryed a very old version of SDRSharp...and it was working.
I've tryed copying the old RTLTCP driver over the new one....
Magically it seems to work perfectly.
You'll miss the RTL ACG and the sample rate dropdown menu.
You can (of course) manually type the sample rate.

That's all, it's working fine till 48hrs at the moment...
The DLL WAS INSIDE a very old version of SDRSharp!
You can download the driver here (just overwrite the original one in SDRSharp folder):

Link n.1
Link n.2



PLEASE,IF YOU LIKE THIS POST, CLICK ON THE BANNERS

5 commenti:

  1. Thanks! Worked for me too!

    RispondiElimina
  2. Grazie, funziona, effettivamente il bug rendeva inutilizzabile rtl_tcp...

    RispondiElimina
    Risposte
    1. Sono molto contento che abbia funzionato pure a te :)

      Elimina
  3. Stuck with this problem for months & almost gave up with using my RTLTCP server. This fixed the problem
    with very little loss of functionality. I had to remember to change the IP back in the connection box of the RTLTCP
    settings, as this was lost on the first try. Thanks very much - I hope the RTL# developers know about the bug.

    RispondiElimina